Gateway para as VLANs no Switch Dell X1052 (Série X1000)

Servidores, Storage & Networking

Servidores, Storage & Networking
Procurando por soluções de negócio mais eficientes? Encontre aqui dicas, tutoriais e respostas para suas dúvidas sobre Servidores, Storage e Redes.

Gateway para as VLANs no Switch Dell X1052 (Série X1000)

Esta pergunta não foi respondida

Boa tarde, Pessoal!

Tenho uma dúvida sobre a configuração do gateway nos meus switchs da rede interna.

Eu tenho no momento 4 VLANs configuradas: 10, 20, 30 e 40 no meu roteador e nos 3 switches. Eles estão organizados conforme a ilustração abaixo.

Porém, pelo que vi na configuração dos switches X1052, eu só tenho como definir um gateway global. Se no Switch P200 eu definir o gateway como sendo o IP da VLAN 10 do Switch Core, todo o tráfego (mesmo vindo das VLANs 20, 30 e 40) passarão para a VLAN 10 quando chegarem no Switch Core e ao chegar no meu roteador, ele interpretará o conteúdo todo como vindo da VLAN 10, mesmo que o IP daquele tráfego seja da VLAN 20.

Na imagem abaixo (logs do roteador) é possível ver que tráfego com o IP 192.168.10.0/24 vêm do LAG01.10 (VLAN 10), mas ele deveria vir do LAG01.20 (VLAN 20). Os IPs da VLAN 10 são 172.16.0.0/16 e os da VLAN 20 são 192.168.10.0/24.

Pergunto: qual seria a forma correta de configurar os switches? Devo eleger uma VLAN para jogar todo o tráfego e no meu roteador eu não configuro as VLANs? Ou correto seria ter um gateway em cada VLAN dos switches (mas não achei essa possibilidade)? Eu uso essa separação no gateway para poder direcionar os tráfegos de cada VLAN e range de IPs em diferentes links de Internet, além de fazer o controle de conteúdo.

Desde já, agradeço a atenção e ajuda.

Abraço.

Rafael.

Todas as respostas
  • Olá, Rafael! Geeked

    Como vai? Tudo bem?

    Desculpe não responder antes.

    Mas vamos lá, pelo que entendi do seu diagrama de rede, na realidade quem vai rotear é o Firewall e não o switch Core.

    Neste caso, todas as VLANs dos switches (menos a 1 que é a de gerência) não precisam ter um IP e as máquinas vão usar como o seu default-gateway o IP da interface do Firewall para aquela VLAN.

    Por isso que está tendo este sintoma estranho. O normal não é o firewall receber os pacotes assim como você mostrou, Rafael.

    Para configurar no seu cenário, basta remover os IP's das VLANs (menos da vlan 1) e botar estes IPs nas VLANs do firewall.

    Espero ter ajudado.

    Até mais! Abraço!

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.