Vlan não navega na internet - N2048

Servidores, Storage & Networking

Servidores, Storage & Networking
Procurando por soluções de negócio mais eficientes? Encontre aqui dicas, tutoriais e respostas para suas dúvidas sobre Servidores, Storage e Redes.

Vlan não navega na internet - N2048

Esta pergunta foi respondida guirfi

Bom Dia a todos do Forum,

Estou com uma duvida em questão a configuração de um switch que possuo, a minha duvida e em questão a vlan aonde o swtch tem duas vlans 50 e 100, pois as maquinas que estão na vlan 50 não consegue navegar na internet. abaixo segue o comando show run.

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2016.12.16 09:35:04 =~=~=~=~=~=~=~=~=~=~=~=


console>em nable

console#show running-config

!Current Configuration:

!System Description "Dell Networking N2048, 6.2.6.6, Linux 3.6.5-50bbccb7"

!System Software Version 6.2.6.6

!

configure

vlan 50,1000

exit

vlan 50

name "TI"

exit

vlan 1000

name "DATACENTER"

exit

slot 1/0 5    ! Dell Networking N2048

stack

member 1 8    ! N2048

exit

ip routing

interface vlan 1

ip address dhcp

exit

interface vlan 50

ip address 192.168.50.250 255.255.255.0

exit

interface vlan 1000

ip address 192.168.0.250 255.255.255.0

exit

ip default-gateway 192.168.0.100

!

interface Gi1/0/5

switchport access vlan 50

exit

!

interface Gi1/0/29

switchport access vlan 1000

exit

!

interface Gi1/0/30

switchport access vlan 1000

exit

!

interface Gi1/0/31

switchport access vlan 1000

exit

!

interface Gi1/0/32

switchport access vlan 1000

exit

!

interface Gi1/0/33

switchport access vlan 1000

exit

!

interface Gi1/0/34

switchport access vlan 1000

exit

!

interface Gi1/0/35

switchport access vlan 1000

exit

!

interface Gi1/0/36

switchport access vlan 1000

exit

!

interface Gi1/0/37

switchport access vlan 1000

exit

!

interface Gi1/0/38

switchport access vlan 1000

exit

!

interface Gi1/0/39

switchport access vlan 1000

exit

!

interface Gi1/0/40

switchport access vlan 1000

exit

!

interface Gi1/0/41

switchport access vlan 1000

exit

!

interface Gi1/0/42

switchport access vlan 1000

exit

!

interface Gi1/0/43

switchport access vlan 1000

exit

!

interface Gi1/0/44

switchport access vlan 1000

exit

!

interface Gi1/0/45

switchport access vlan 1000

exit

!

interface Gi1/0/46

switchport access vlan 1000

exit

!

interface Gi1/0/47

switchport access vlan 1000

exit

!

interface Gi1/0/48

switchport access vlan 1000

exit

snmp-server engineid local 800002a203f48e380a9bad

exit

Desde de já muito obrigado a todos.

att,

Guilherme Figueiredo

Resposta verificada
  • Boa Tarde Antonio tudo bem?

    Cara deu CERTO !!!! configurei uma porta para trunk (passei as VLANS) coloquei o firewall e declarei as redes nele, navegou como uma beleza.

    Só estou com uma duvida se eu colocar esse SW em steack ele replicara as configurações, se vc tiver o link de documentação de steak ficaria grato.

    att,

    Guilherme Figueiredo

Todas as respostas
  • Olá, Guilherme!

    Como vai? Tudo bem?

    Guilherme, você já fez o mais difícil e que muita gente pergunta aqui no fórum que é fazer o switch rotear entre as VLANs. Ou seja, as máquinas da VLAN 50 pingam as máquinas da VLAN 1000.

    Parabéns! Yes Geeked

    Agora é "botar a cerejinha em cima do bolo" Big Smile

    Ou seja: o seu firewall ou roteador de Internet tem que saber como voltar os pacotes para a VLAN 50 pois se você observer bem a configuração, vai ver que a rota default do switch é o IP 192.168.0.100.

    Então, esta máquina de IP 192.168.0.100 tem que saber chegar na rede 192.168.50.x .

    Por isso você precisa configurar uma "rota de retorno".

    Por exemplo, se o 192.168.0.100 for um linux, pode fazer algo assim:

    ~]# ip route add 192.168.50.0/24 via 192.168.0.250

    Mais sobre isso pode ser visto nos fóruns sobre linux. O comando acima eu tireti do help do RedHat linux.

    https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/5/html/Deployment_Guide/s1-networkscripts-static-routes.html

    https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Deployment_Guide/sec-Configuring_Static_Routes_in_ifcfg_files.html#sec-networkscripts-static-routes-ip-command

    Depois você nos conta se ficou ok.


      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

     

  • Boa Noite Antonio,


    Muito Obrigado pela resposta rapida e desculpe a demora em responder,

    se trata de um Firewall Sonicwall Tz 300.

  • Olá, meu caro! Obrigado Pelo retorno!

    Achei que você já tinha resolvido.Geeked

    Apesar de ser um produto Dell, a SonicWall tem um time de suporte em separado.

    Eu não sou especialista em SonicWall. Mas... Wink Firewall é Firewall! hehehehe Todos seguem a mesma lógica!

    A idéia da rota de retorno permanece.

    Abaixo segue um artigo do site de suporte da SonicWall explicando como fazer e ainda com um exemplo de rede igualzinho ao seu.

    https://support.sonicwall.com/kb/sw3559

    Tenho certeza que você consiguirá implementar sozinho.

    Abraço! YesCool

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

     

  • Opá Antonio muito obrigado pelas respostas.

    eu sei que estou quase conseguindo pois o firewall consegue pingar as Vlans mas não consegue pingar o Host

    mas obrigado

    abraço

  • Que bom, Guilherme!

    Então é uma questão de verficar se o gateway padrão dos hosts é o IP da VLAN que eles fazem parte. Se isto estiver correto, não tem como não funcionar.

    Abraço e Feliz Ano Novo! YesCool

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

     

  • Boa Tarde Antonio tudo bem?

    Cara deu CERTO !!!! configurei uma porta para trunk (passei as VLANS) coloquei o firewall e declarei as redes nele, navegou como uma beleza.

    Só estou com uma duvida se eu colocar esse SW em steack ele replicara as configurações, se vc tiver o link de documentação de steak ficaria grato.

    att,

    Guilherme Figueiredo

  • Olá, Guilherme!

    Que beleza! Maravilha! Funcionou. Parabéns. No final a configuração estava no firewall mesmo. Yes

    E sim, Guilherme, a stack replica tudo para as outras unidades.

    A documentação de stack é a do produto mesmo.

    Você pode baixar o Guia do Usuário aqui.

    Tem ainda este artigo da base de conhecimento oficial Dell.

    Fico satisfeito em ter ajudado.

    Até mais! CoolYes

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.