Configurar rota PowerConnect 6248

Servidores, Storage & Networking

Servidores, Storage & Networking
Procurando por soluções de negócio mais eficientes? Encontre aqui dicas, tutoriais e respostas para suas dúvidas sobre Servidores, Storage e Redes.

Configurar rota PowerConnect 6248

Esta pergunta foi respondida HelderFreitas76

Bom dia!

Por gentileza, preciso de ajuda para configurar rotas em um switch PowerConnect 6248 que atualmente esta em uma unica vlan. Agora preciso rotear o trafego de diversos IPs para encaminhar para uma unica porta com o links da rede nova.

Desde já, muito obrigado.

Att.
Helder Freitas

Resposta verificada
  • Helder, Bom dia! Geeked

    Que bom que agora você conseguiu chegar até aqui com a nossa ajuda. Obrigado por não desistir!Yes E parabéns pela paciência!

    Por favor, Helder, nos avise aqui no fórum se o pessoal da operadora adicionou as rotas de retorno e isto funcionou ou se fizeram algo mais, ok?

    Assim todos do fórum podem se beneficiar do conhecimento gerado.

    Por sinal, quem quiser ler os posts completos pode acessar este link.

    Até a próxima!

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

     

  • Antonio, boa tarde!

    Ultimo capitulo!!!


    Foi criado a rota de retorno no roteador da operadora e conseguimos fechar a conexão.

    Muito obrigado pela ajuda, sem ela não teria conseguido.

    Grande abraço.

    Helder 

Todas as respostas
  • Olá, Helder!

    Como vai? Tudo bem?

    Helder, a sua pergunta já foi respondida aqui no fórum pela Ananda neste post.

    Apenas além do que está lá, você vai ter uma interface VLAN em uma porta de acesso apenas para ela. Esta vai ser a porta que vai receber o firewall.

    Espero ter ajudado. YesGeeked

    Até mais!

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

     

  • oi Antonio,

    Tudo bem, e você?

    Muito obrigado pela atenção.

    Já havia lido o post da Amanda, e realmente ele esclarece a questão da VLAN, mas acho que na minha pergunta não consegui explicar as minhas necessidades de roteamento.

    VLAN X = 172.16.0.0/16 e GW padrão 172.16.0.1

    VLAN Y = 192.168.1.x/24 e GW padrão 192.168.1.1


    Tenho hoje um switch 6248 com somente a VLAN X.

    Preciso criar a VLAN Y (o post da Amanda esclareceu perfeitamente)

    E rotear o trafego da VLAN X que buscam os IPs das redes: 10.10.10.0/24, 10.10.20.0/28, 10.10.30.0/28 e 186.186.186.186/29, para sair pela VLAN Y.

    Desde já agradeço a atenção.

    Att.
    Helder

  • Olá, Helder!

    Tudo bem?!

    Helder, você está querendo adicionar rotas para as redes remotas (10.10.10.0/25 ; 10.10.20.0 /28 ; 10.10.30.0 /28 e 186.186.186.186/29) tendo como endereço de saída (gateway) um ip da VLAN Y. Assim, as suas VLANs (redes locais) vão conseguir acessar as redes remotas.

    Bom, Helder, digamos que o endereço IP da VLAN Y seja 192.168.1.1 e o IP da máquina que possui acesso 'as redes remotas seja 192.168.1.254, então você deve usar este endereço como gateway na hora de dar o comando de adicionar rota estática (manual).

    Exemplo:

    console(config)# ip route 10.10.10.0 /24 169.168.1.254

    ou

    console(config)# ip route 10.10.20.0 255.255.255.240 192.168.1.254

    E assim por diante usando a sintaxe geral:

    (config)# ip route <rede de destino> <máscara> <ip do gateway>

    Creio que isto vai resolver.

    Até mais! YesGeeked

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

     

  • Antonio, boa noite.

    Mais uma vez muito obrigado pela ajuda.

    Criei a vlan, setei a ethernet da porta no switch e fiz as rotas conforme você indicou, mas o roteamento não esta funcionado.

    Consigo pingar o ip da interface da vlan Y 192.168.1.1, mas não consigo alcançar a maquina da rede remota 192.168.1.254.

    Alguma ideia onde pode estar o problema.

    Desde já muito obrigado.

    Att.

    Helder

  • Olá, Helder! Geeked

    Parece que está tudo certo, então. Se você configurou o switch conforme nós dois descrevemos, então o diagrama de rede deve estar como na figura abaixo:

    Se não consegue pingar a máquina 192.168.1.254, talvez seja por que ela está conectada numa porta que não é de acesso na VLAN Y.

    Por favor, Helder, certifique-se que a máquina 192.168.1.254 está numa porta da VLAN Y.

    Aguardamos o resultado.

    Até mais!YesCool

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

     

  • Antonio, boa tarde!

    A maquina 192.168.1.254 esta conectada na porta correta da VLAN Y (1/g44).

    O diagrama da rede esta correto, a unica diferença é que a VLAN X é a VLAN ID 1 default do switch 6248.

    Segundo um dos post deste fórum neste link, a VLAN ID 1 dos switch da DELL são layer 2, por isso não aceita o roteamento. 

    Poderia ser esse o problema? Se criasse uma VLAN e passasse as portas para ela resolveria o problema de roteamento?

    Mais uma vez agradeço muito pela ajuda.

    Att.,

    Helder

  • Olá, Helder!

    Excelente pesquisa!YesCool

    Está parcialmente correto isso de a VLAN 1 ser Layer 2 apenas. O detalhe é que isto não é para sempre e não vale apenas para a vlan 1 (default / nativa / gerência).

    Qualquer VLAN que a gente criar tem que lembrar de entrar nela e habilitar o roteamento assim:


    console#conf
    console(config)#interface vlan 1
    console(config-if-vlan1)#routing
    console(config-if-vlan1)#end
    console# copy run star

    Ou ainda

    console#conf
    console(config)#vlan database
    console(config-vlan)#vlan routing 1
    console(config-vlan)#end
    console# copy run star

    Isso vale para qualquer ID de vlan, Helder.Geeked

    Se o ainda não estava configurado assim, pode corrigir que vai funcionar.

    Pergunta: qual é a versão do firmware do seu 6248?

    Até mais!

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

     

  • Antonio, bom dia!

    Mais um capitulo da saga ... kkk

    A versão do firmware é a 3.3.15.1.

    Quando executei o 1º bloco de comando pela 1ª vez, no comando routing deu a seguinte mensagem de erro:
    ERROR: Routing is not allowed on the Management VLAN.

    Depois executei novamente os comandos, não apareceu mais a mensagem de erro, mas não funciona o reteamento.

    Ainda não estou conseguindo pingar no IP 192.168.1.254. Se tento um tracert para o IP 192.168.1.254

    Mais uma vez, muito obrigado.


    Att.,

    Helder Freitas

  • Desculpa, enviei a mensagem sem terminar a frase.

    Se tento um tracert para o IP 192.168.1.254, já esgota o tempo no 1º salto.

    Att.,

  • Perfeito. Entendi, Helder.

    Neste caso é normal esgotar o tempo no primeiro salto por que o switch possui de fato uma interface diretamente conectada que é a VLAN Y.

    Só podemos concluir que a máquina com IP 192.168.1.254 está configurada para não responder ICMP (ping e tracert).

    Se você der o comando show arp switch tem que ao menos ter uma entrada ali para o endereço IP que você pingou ou deu traceroute. Se não existir, então o firewall daquela máquina é muito bom mesmo!

    Mas ainda podemos testar o seguinte: "show bridge address-table ethernet 1/gXX" onde XX é o número da porta. Tem que dar o mac address da NIC daquela máguina ali conectada.

    Em último caso, podemos ainda dar os comandos: "show lldp remote-device all" e ver quem responde a detecção do LLDP em cada porta conferindo o mac address; ou ainda "show isdp neighbor detail" para ver que máquinas respondem a detecção ISCP também identificando o mac, ou modelo, ou outra descrição que a máquina possua, Helder.

    Eu estou desconfiado que você tem alguma coisa cabeado errado ou esta máquina que vai rotear para aquelas redes tem um firewall muito severo que não deixa passar nada!

    Vamos ver como faremos pois esta é uma segunda parte do problema.

    Até mais!

    YesCool

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

     

  • Bom dia, Helder! Tudo certo?

    hahahahaha! Big Smile Muito boa a nossa saga!

    Mas veja o lado bom, quando muda a mensagem de erro é porque estamos mais perto da solução.Wink

    Interessante é que você possui a mesma versão de firmware que eu tenho no lab.

    Pelo que um colega mais antigo me falou, este switch faz o roteamento da VLAN 1 mas de modo incompleto.

    Portanto, Helder, o melhor é mesmo trocar as portas para uma VLAN 2 por exemplo, depois tirar o endereço IP da VLAN 1 e colocar na VLAN 2. Daí habilitar o roteamento na VLAN 2 e deixar a VLAN 1 com uma outra faixa de IP apenas para poder monitorar e gerenciar.

    Estamos aqui para ajudar, Helder. Não vamos desistir enquanto não funcionar.

    Até mais! YesCool

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

     

  • Antonio, boa tarde!

    Vamos para mais um capitulo... kkk

    Criei as configurações das 2 VLAN conforme o post da Amanda e as rotas que você havia passado, mas mesmo assim não consigo alcançar as rede da VLAN Y.

    Nas configurações sugeridas pela Amanda não consigo configura o DHCP com o comando "Bootpdhcprelay serverip 172.1.0.2", pois não existe a opção do parâmetro serverip para o comando Bootpdhcprelay, utilizei o comando "ip helper-address 172.16.0.2 dhcp". Mas acredito que não seja esse o problema de roteamento do Switch. 

    Quanto ao firewall da ponto da VLAN Y, podemos descartar, pois ao configura um notebook direto no roteador link da VLAN Y (192.168.1.254), conseguimos pingar e efetuar tracert para todas as redes desta VLAN.

    Na ARP table, é possível visualizar o registro do IP 192.168.1.254 e o Type dele esta como Gateway.

    Segue a configuração do switch:

    !Current Configuration:
    !System Description "PowerConnect 6248, 3.3.15.1, VxWorks 6.5"
    !System Software Version 3.3.15.1
    !Cut-through mode is configured as disabled
    !
    configure
    vlan database
    vlan 10,20
    vlan routing 10 1
    vlan routing 20 2
    exit
    hostname "SW_CORE_1"
    sntp unicast client enable
    sntp server 172.16.0.4
    sntp server 172.16.0.2
    clock timezone -3 minutes 0
    stack
    member 1 2
    exit
    ip address 172.17.0.254 255.255.255.0
    ip default-gateway 172.17.0.1
    ip name-server 172.16.0.1
    policy-map SolftPhone in
    exit
    ip routing
    ip route 192.168.1.0 255.255.255.0 192.168.1.254
    ip helper-address 172.16.0.2 dhcp
    interface vlan 10
    name "PRINCIPAL"
    routing
    ip address 172.16.0.254 255.255.0.0
    exit
    interface vlan 20
    name "MPLS"
    routing
    ip address 192.168.1.100 255.255.255.0
    exit
    username "Administrador" password xxxxxxxxxxxxxxxx level 15 encrypted
    aaa authentication login "defaultList" line
    aaa authentication enable "enableList" line
    monitor session 1 destination interface 1/g27
    monitor session 1 source interface 1/g12
    monitor session 1 source interface 1/g13
    monitor session 1 mode
    line console
    password xxxxxxxxxxxxxxxx encrypted
    exit
    line telnet
    password xxxxxxxxxxxxxxxx encrypted
    exit
    spanning-tree priority 0
    ip dhcp snooping
    dhcp l2relay
    dhcp l2relay vlan 10,12,14
    dhcp l2relay circuit-id vlan 10,12,14
    classofservice trust ip-dscp
    classofservice ip-dscp-mapping 46 5
    !
    interface ethernet 1/g1
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g2
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g3
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g4
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g5
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g6
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g7
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g8
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g9
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g10
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g11
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g12
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g13
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g14
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g15
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g16
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g17
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g18
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g20
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g21
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g22
    ip dhcp snooping trust
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g23
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g24
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g25
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g26
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g27
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g28
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g29
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g30
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g31
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g32
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g33
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g34
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g35
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g36
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g37
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g38
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g39
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g40
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g41
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g42
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g43
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g44
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g45
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g46
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g47
    switchport access vlan 10
    exit
    !
    interface ethernet 1/g48
    switchport access vlan 20
    exit
    exit

    Mais uma vez, agradeço imensamente a ajuda recebida.

    Att.,
    Helder Freitas

  • Olá, Helder! Geeked

    Que bom que estamos progredindo! Vamos lá! Um capítulo após o outro!Big Smile

    O DHCP relay não possui relação  direta com o problema do roteamento.

    O roteamento está correto se você cologou um notebook na mesma porta e configurou o mesmo endereço IP. Ou seja, o pacote está sendo entregue.

    Talvez não esteja sendo entregue da melhor maneira, Helder.

    Pelo que temos no seu running-config, a rota não está correta mesmo.

    Do jeito que está ali, não há como o switch saber retornar para a rede remota, apenas a rede local. Abaixo segue o que você tem configurado:

    ip route 192.168.1.0 255.255.255.0 192.168.1.254

    Deveria ser:

    ip route 10.10.10.0 255.255.255.0 169.168.1.254

    Ou seja: "ip route <endereço da rede remota> <máscara> <ip do gateway>" numa sintaxe geral

    Então teremos ainda para a outra rede remota seguindo a mesma lógica:

    ip route 10.10.20.0 255.255.255.240 192.168.1.254

    E assim por diante...

    Não se esqueça e retirar aquela rota errada com :

    no ip route 192.168.1.0 255.255.255.0 192.168.1.254

    Vamos lá, Helder! Estamos muito perto do final da saga!

    Até mais!YesCool

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

     

  • Antonio, boa noite!

    Acertei as rotas:

    ...

    ip routing
    ip route 10.10.10.0 255.255.255.0 192.168.1.254
    ip route 10.10.20.0 255.255.255.240 192.168.1.254
    ip route 10.10.30.0 255.255.255.240 192.168.1.254
    ip route 186.186.186.186 255.255.255.248 192.168.1.254
    ip helper-address 172.16.0.2 dhcp

    ...

    Mas ainda não consigo alcançar os IPs roteados.

    Att.,

    Helder

  • Olá, Helder!

    Que bom ver que você acertou as rotas!

    Agora temos que fazer o "caminho de volta", ou seja, inserir a rota para que a máquina 192.168.1.254 saiba chegar na rede 172.16.0.x e 172.17.0.x .

    Qual é o Sistema Operacional do 192.168.1.254?

    Ate´mais!

    *Editado pelo próprio moderador:

    Helder postou outra resposta para o mesmo caso aqui nesta outra postagem do fórum.

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.