Configuração de VLANS e Porta Trunk series X1000

Servidores, Storage & Networking

Servidores, Storage & Networking
Procurando por soluções de negócio mais eficientes? Encontre aqui dicas, tutoriais e respostas para suas dúvidas sobre Servidores, Storage e Redes.

Configuração de VLANS e Porta Trunk series X1000

Esta pergunta foi respondida DELL-Antonio M

 Boa Noite a todos, 

Estou com uma pequena duvida referente a essa serie de SW da Dell, Vamos la:

A estrutura esta da seguinte forma:

Possuo 2 SW core da Serie N3000 ligados em Stack, as VLans já estão configuradas, IPs de VLans tambem, e eu preciso configurar 1 ou mais portas em modo trunk nele e tambem no SW x1000, a questão é o seguinte, eu coloquei a porta do Core em modo trunk e passando todas as vlans.

Mas quando chego para configurar no SW X1000 estou apanhando, não entendi muito bem essa modo tag e untag.

Informei a porta do X1000 para trunk e permiti todas a vlans e tambem apresente uma porta qualquer para a VLAN e mesmo assim não consegui acesso ou até mesmo pingar o SW core.

Tentei tambem configurar via CLI como de costume mas percebi que existe comandos que não existe, estou apanhando muito no GUI.

Poderia me ajudar nesse caso?

Desde já agradeço.

Resposta verificada
  • Guilherme, se o Firewall vai realizar o roteamento esta conexão está correta.

    Entretanto se o Firewall rotear o switch Core não precisa realizar o roteamento entre as VLANs.Surprise

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

     

Todas as respostas
  • Olá, Guirfi!

    Sua dúvida é muito boa e ocorre bastante.

    Inclusive já respondi antes aqui neste outro post.

    Por favor, leia este outro post e se você ainda não entender podemos tratar com mais detalhes aqui.

    Até mais!YesCool

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

     

  • Bom Dia Antonio, 

    Muito Obrigado pela ajuda. 

    Irei verificar a configuração e te dou um retorno aqui, poderia me informar um link valido para  o" guia do usuario", pois aquele esta off.

    muito obrigado

  • Bom dia, Guirfi! Geeked

    Claro, sem problemas!

    Seguem os links:

    Até mais! YesCool

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

     

  • Olá Antonio tudo bem?

    "e volta o cão arrependido, com o rabo entre as pernas...." hahahahhaahah,

    Li o material e tentei fazer a configuração e mesmo assim não estou conseguindo que a VLAN no SW de acesso chegue ao SW CORE.

    Efetuei as seguintes configurações no switch core:

    console(config)#interface gigabitethernet 1/0/10

    console(config-if-Gi1/0/10)#switchport mode trunk 

    console(config-if-Gi1/0/10)#switchport trunk encapsulation dot1q

    console(config-if-Gi1/0/10)#switchport trunk allowed vlan all

    E no SW x1000, apresentei as mesmas VLANs com os mesmo IDs e apresentei a porta 1/0/1 como trunk e passando todas as VLANS 

    E quando apresento uma porta para uma VLAN ela não Navega, nem pinga nem nada hauahuauahuhauha.

    poderia me ajudar?

  • hahahaha

    Maravilha de feedback, Guirfi! Big Smile

    É bom manter o bom humor nessas horas!

    Pelo que podemos ver, o problema não deve estar na interligação entre os switches, ou seja: não está no trunk.

    Então talvez seja algo na porta de acesso mesmo ou no PC que fica nesta VLAN.

    Vejamos, Guifi: se você tem no X 1000 uma VLAN 10 e a faixa de enderço dessa VLAN é 192.168.10.xxx com máscara 255.255.255.0 . Aí  se botar as portas 11 e 12, por exemplo, nesta VLAN 10 , considerando que as máquinas estão com endereço IP correto, elas conseguem pingar uma na outra?

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

     

  • Então esse teste ainda não cheguei a fazer e como os equipamentos não estão em meu poder não irei conseguir, mas veja oque eu ja fiz:

    Configurei as portas como TRUNK em ambos os SW até ai bele.

    Configurei uma porta e atribui ela a uma VLAN (ex10), e tentei pingar o IP de gerenciamento do SW CORE e o GW de VLAN e foi sem sucesso.

  • Entendi. Hmm

    Mas a porta onde o GW da VLAN 10 está conectado em uma porta também da VLAN 10 ?

    Confused

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

     

  • Sim atribui uma porta na VLAN 10 e coloquei os IP referente a essa VLAN

    IP 192.168.10.2

    Mask 255.255.255.0

    GW 192.168.10.1

    Fiz um lab no packet tracert aonde funcionou, aonde coloquei um L3 e um L2, configurei os TRUNKs entre ele, e segmentei as portas do L2, coloquei as maquinas com os devidos IPs de suas VLANs. 

    Creio que esteje errando nesse Tag e Untag, tanto nas portas de acesso como na porta de trunk.

    Pelo "GUI" eu me perco.

  • hehehe! Big Smile

    Confeço que também me perco na GUI!Stick out tongue

    Mas é tudo uma questão de entender bem o conceito de Tag e Untag.

    Como você mesmo disse, talvez esteja errando o tag e untag nas portas de acesso e trunk.

    Vamos lá:

    1. As portas entre os switches tem que ser Trunk. T de Trunk , T de Tag. Logo, todas as VLANs são Tagged nas portas trunk, exceto a VLAN 1 que é a gerência/nativa.
    2. As portas que conectam as máquinas (PCs, Notes, impressora IP, etc...) são chamadas portas de acesso. Portanto elas tem que ser portas em Access Mode, nunca Trunk. Nestas portas as VLANs nunca são tagueadas - são sempre Untagged.

    Talvez se você enviar a config dos switches no packet tracer e a topologia eu possa adaptar a configuração para os X Series.

    Fico no aguardo!

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

     

  • Antonio, aproveitando seu conhecimento, queria fazer as seguintes perguntas.

    Referente a IP de Gerenciamento nos SWs.

    Todos os SW vem por padrão a VLAN 1 como VLAN nativa e assim vc pode transformar ela em VLAN de gerenciamento(oque não é recomendavel).

    Seguindo esse linha de pensamento tenho as seguintes perguntas:

    - colocando o IP de gerenciamento nos SWs(CORE e ACESSO), os "ip default-gateway" do SW de Acesso será o IP do CORE e do CORE será o FIREWALL, é certo fazer?.

    Nessa conf que estou te mandando eu fiz da seguinte maneira 

    IPs de gerenciamento dos SW são 10.10.1.X/24.

    Abaixo as configurações dos SW_CORE:

    SW_CORE#show run

    Building configuration...

    Current configuration : 1709 bytes

    !

    version 12.2

    no service timestamps log datetime msec

    no service timestamps debug datetime msec

    service password-encryption

    !

    hostname SW_CORE

    !

    enable secret 5 $1$mERr$QJxDeNCP2Xze0Xk2Hvlxr.

    !

    ip routing

    !

    !

    spanning-tree mode pvst

    !

    interface FastEthernet0/1

    switchport trunk encapsulation dot1q

    switchport mode trunk

    !

    interface FastEthernet0/2

    switchport trunk encapsulation dot1q

    switchport mode trunk

    !

    interface FastEthernet0/3

    switchport access vlan 100

    switchport mode access

    !

    interface FastEthernet0/4

    !<...>

    interface FastEthernet0/24

    !

    interface GigabitEthernet0/1

    !

    interface GigabitEthernet0/2

    !

    interface Vlan1

    ip address 10.10.1.1 255.255.255.0

    !

    interface Vlan10

    ip address 192.168.10.1 255.255.255.0

    ip helper-address 192.168.0.2

    !

    interface Vlan20

    ip address 192.168.20.1 255.255.255.0

    ip helper-address 192.168.0.2

    !

    interface Vlan100

    ip address 192.168.0.1 255.255.255.0

    !

    ip classless

    !

    ip flow-export version 9

    !

    !

    end

    --------------------------------------------------------------------------------------------------------------------------------------------

    SW_ACCESS

    SW_ACCESS#show run

    Building configuration...

    Current configuration : 2118 bytes

    !

    version 12.1

    no service timestamps log datetime msec

    no service timestamps debug datetime msec

    no service password-encryption

    !

    hostname SW_ACCESS

    !

    enable secret 5 $1$mERr$QJxDeNCP2Xze0Xk2Hvlxr.

    !

    spanning-tree mode pvst

    !

    interface FastEthernet0/1

    switchport mode trunk

    !

    interface FastEthernet0/2

    switchport access vlan 10

    switchport mode access

    !

    interface FastEthernet0/3

    switchport access vlan 10

    switchport mode access

    !

    interface FastEthernet0/4

    switchport access vlan 10

    switchport mode access

    !

    interface FastEthernet0/5

    switchport access vlan 10

    switchport mode access

    !

    interface FastEthernet0/6

    switchport access vlan 10

    switchport mode access

    !

    interface FastEthernet0/7

    switchport access vlan 10

    switchport mode access

    !

    interface FastEthernet0/8

    switchport access vlan 10

    switchport mode access

    !

    interface FastEthernet0/9

    switchport access vlan 10

    switchport mode access

    !

    interface FastEthernet0/10

    switchport access vlan 10

    switchport mode access

    !

    interface FastEthernet0/11

    switchport access vlan 20

    switchport mode access

    !

    interface FastEthernet0/12

    switchport access vlan 20

    switchport mode access

    !

    interface FastEthernet0/13

    switchport access vlan 20

    switchport mode access

    !

    interface FastEthernet0/14

    switchport access vlan 20

    switchport mode access

    !

    interface FastEthernet0/15

    switchport access vlan 20

    switchport mode access

    !

    interface FastEthernet0/16

    switchport access vlan 20

    switchport mode access

    !

    interface FastEthernet0/17

    switchport access vlan 20

    switchport mode access

    !

    interface FastEthernet0/18

    switchport access vlan 20

    switchport mode access

    !

    interface FastEthernet0/19

    switchport access vlan 20

    switchport mode access

    !

    interface FastEthernet0/20

    switchport access vlan 20

    switchport mode access

    !

    interface FastEthernet0/21

    !

    interface FastEthernet0/22

    !

    interface FastEthernet0/23

    !

    interface FastEthernet0/24

    !

    interface Vlan1

    ip address 10.10.1.2 255.255.255.0

    !

    ip default-gateway 10.10.1.1

    !

    end

    --------------------------------------------------------------------------------------------------------------------------------------------

  • Boa Noite Antonio Tudo Bem?.

    Consegui realizar a configuração do SW X1000 para o N3000.

    Agora surgiu outra questão, referente ao IP de gerenciamento do SW x1000, modifiquei ele e coloquei na mesma rede que o IP de gerenciamento do N3000, porem quando tento efetuar o Ping do SW x1000 para o SW N3000 não funciona, coloquei o IP default-gateway do x1000 sendo o N3000.

    Tambem quando estou em uma VLAN(ex10) consigo pingar o IP de gerenciamento do N3000 e até mesmo acessar o firewall.

    Alem de ajudar nisso, queria saber quais são as boa praticas para configuração de IP de gerenciamento.

    att,

    Guilherme Figueiredo

  • Olá, Guilherme!

    Obrigado pelo retorno! Que bom que você conseguiu progredir.

    Vou responder aqui também seus questionamentos:

    • Todos os SW vem por padrão a VLAN 1 como VLAN nativa e assim vc pode transformar ela em VLAN de gerenciamento(oque não é recomendavel).

    Resposta: Isso não é completamente um problema. Basicamenete a Cisco recomenda não usar a VLAN 1 como nativa para proteger a sua topologia de spanning-tree quando misturar switches de fabricantes diferentes na rede. Isso de usar a VLAN 1 como nativa e gerência não chega a ser um problema se todos os switches também usarem e se você usar os outros meios de proteção do spanning-tree (portfast e bpduguard).

    • colocando o IP de gerenciamento nos SWs(CORE e ACESSO), os "ip default-gateway" do SW de Acesso será o IP do CORE e do CORE será o FIREWALL, é certo fazer?.

    Nessa conf que estou te mandando eu fiz da seguinte maneira 

    IPs de gerenciamento dos SW são 10.10.1.X/24.

    Está ok. Pode configurar assim que está correto e funciona. Apenas um detalhe: a faixa de IP e VLAN do Firewall é outra VLAN que não é a VLAN 1, correto? Se for assim, tudo bem!

    Até mais! Que bom que estamos bem perto de solucionar tudo!

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

     

  • Ola Antonio, 

    Vish aii complicou referente a conexão entre o SW e o FRW, Pois ele estão na mesma VLAN 1.

    IP do Frw = 10.10.1.254/24.

    IP do SW = 10.10.1.249/24.

    Nesse caso como seria melhor fazer?, Criaria uma VLAN(ex 101) ? e conectaria a LAN do FRW na Lan CORE?, Seria necessario configurar um IP nessa VLAN?.

    Digo isso pq nessa topologia que esta agora, consigo pingar SW, FRW e Internet.

  • Atualizando:

    a porta que o firewall esta conectada no SW é a porta Gi 1/0/1, que esta em TRUNK passando todas as vlans: seria essa a configuração?

    As rede já estão apresentadas para o FRW(Sonicwall).

  • Guilherme, se o Firewall vai realizar o roteamento esta conexão está correta.

    Entretanto se o Firewall rotear o switch Core não precisa realizar o roteamento entre as VLANs.Surprise

      Antonio Moraes
     Fórum Moderator
     Enterprise ProSupport

    Chat | Twitter | Facebook | 0800 970 3355

    Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.